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Introduction to roundtrip 

Roundtrip – what does it mean? 
In order to explain the term that has slowly but surely domesticated in the vocabulary of 
engineers, we refer to the White Paper Roundtrip Engineering in Construction - Integrated 
CAE-CAD solutions for specific market segments by J.P. Rammant, CEO of SCIA 
International in March 2006. 
Start of quotation: 

 
Practically every design of a construction is an iterative process of refining, reviewing, changing 
architectural, engineering or building (fabrication) details. Therefore, a roundtrip solution, where 
a designer or detailer can start or edit the model at any stage, is closest to reality and will lead to 
the shortest time between design and fabrication or building. 
Reverse engineering reconstructs the design model from the CAD geometrical model, again an 
extra benefit. 
Roundtrip engineering is being achieved by SCIA through a joint development with Nemetschek 
of a common interface between two platforms, one for CAE and for CAD. 
Complex CAE calculations may be executed, hidden to the normal CAD user. 

 
The Scia Engineer (Professional Technology) platform addresses CAE modelling, with a 
consistent structural and analysis model for steel and concrete building parts & structures. The 
structural objects are directly linked with corresponding parts within the Allplan platform, using 
the Nemetschek Object Interface. Steel sections and concrete constructive elements are one-to-
one compliant. 
In contrary to a link based on IFC between models of a same domain, here a transfer between a 
CAE and CAD model is being realized (in both directions). 
Roundtrip is much more than import / export. Some extra benefits which are being implemented: 
- the upgrade engine keeps the CAE and CAD model compatible; outside data (e.g. design data) 
are stored as Blob (Binary Large Objects) properties 
- labels remain positioned in associated views after changes 
-refinements and changes are possible in selected parts of a construction; they will be 
transferred to the other application. 
  
... 
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- fast modelling techniques in one platform are reflected in the other platform 
  
... 
  
SCIA is addressing the functionality of the Allplan platform concerning modelling of steel 
reinforcement. 
Also with other CAD modelling systems such as Revit (Autodesk) SCIA is implementing the 
highest functional link; Revit is providing an API (Programming Interface) that allows partly 
roundtrip engineering. With Revit Structures SCIA will have a link to the Scia Engineer analysis 
model. It means that from Revit Structures the input of geometry and loading will be exported 
directly to SCIA .Scia Engineer. Changes to the structural model can be imported in the 
structural model of Revit. 
  
... 
... 
... 
  
Roundtrip engineering is drastically improving the design process; it is the most advanced 
implementation of Building Information Modelling technology. Integrated open general CAE-CAD 
platforms provide customized solutions without the necessity of dedicated programming. Ease of 
use and far going automation are key elements of the success. 
  
End of quotation. 
  

Roundtrip (including the one-way import / export) in SCIA. Scia Engineer 

Format or Program Import Export Update 
(Roundtrip)

SCIA .Scia Engineer yes yes yes 

XML yes yes yes 

IFC 2x3 yes yes yes 

Revit yes yes yes 

Graphic format (excluding DXF, DWG, 
VRML) 

--- yes --- 

DXF, DWG, VRML yes yes --- 

DSTV yes yes --- 

ProSteel yes yes yes 

StepSteel (analysis model) yes yes --- 

StepSteel (structural model) yes yes --- 

CEA Pland-4D --- yes --- 

  
In the program itself (Scia Engineer), the functions are distributed over several different menus 
and tree menus: 
 File > Import, 
 File > Export, 
 File > Update, 
 service Structure > Drawing tools > Import DWG, DXF, VRML97 file, 
 service Tools > XML, 
 service Structure > Import ESA project. 
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Scia Engineer 

Scia Engineer 
Scia Engineer enables the user to perform the import, export and update operations not only 
through "third-party format" files, but also directly through the .ESA file (i.e. the "native" format of 
Scia Engineer). 
This capability opens the user new horizons. He/she can share data with the colleagues. He/she 
can add into the currently processed project parts from older projects (and thus save 
considerable amount of time). The work on one large project can be split among several users 
and the final model can be "glued" from several parts. 

Scia Engineer import 

The procedure to import data from .ESA file 
1. Open service Structure. 
2. Start function Import ESA project. 
3. Browse for the required input file. 
4. Confirm the file. 
5. Input the "point of insertion" for the imported data. 

  

Note: Contrary to imports through other formats, this time the specified file is added to the currently 
edited project. 

Scia Engineer export 

The procedure to export data into .ESA file 
1. Start menu function File > Export > New project ESA. 
2. Specify the required output folder. 
3. Type the name of the file (i.e. the base name without extension). 
4. The Import/Export dialogue is opened on the screen. 
5. Specify which types of data are to be exported (only geometric entities or the whole 

model).¨ 
6. Complete the export operation. 

Scia Engineer update 
This function enables the user to exchange and share project data with colleagues who use Scia 
Engineer as well. 
The principle is simple. User A makes the first version of the project and sends it to the user B. 
User B continues with the project and then returns it back to user A. Naturally, user A may have 
made some changes during this period too. 
Now comes the time for Scia Engineer and its Update function. This function compares the two 
projects and finds added, deleted and modified entities. Everything is clearly summarised in a 
neat dialogue. Finally, it is the user’s turn again to decide which variants are those to be kept for 
future work. 

The procedure to import and compare the project processed by a third-party user 
1. Open your version of the project. 
2. Call function File > Update > ESA file. 
3. Browse for the file with the version that should be compared. 
4. The program reads the project file and opens the Update dialogue. 
5. Decide which changes are to be accepted and which ones are to be declined. 
6. Confirm with button [Accept]. 
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Scia Engineer update dialogue 
The dialogue is a three-pane dialogue with a toolbar. The panes are: 
 preview window, 
 property window, 
 merge window. 

Toolbar 
The control icons are mostly taken over from a standard Scia Engineer graphical window. 
Therefore, their meaning will not be discussed in detail here. 

View parameters icons 
These icons enable the user to adjust "what" and "how" should be displayed. 

View-adjustment icons 
These icons make it possible to set the view direction. 

Zoom icons 
These icons enable the user to zoom-in or -out the model. 

Clipping box icons 
These icons control the clipping box. 

Special icons 

Generate report This icon generates a report about the 
update. 

Display original 
entities 

If ON, the original entities are displayed. 

Display merged 
entities 

If ON, the merged entities are displayed. 

  

Preview window 
The Preview window is a standard graphical window used throughout Scia Engineer. 
The window supports standard features of Scia Engineer graphical windows: 
(i) pop-up menu with a set of zoom, print, save etc. functions, 
(ii) [Ctrl] + [Shift] + right-click and drag to zoom in and out the drawing, 
(iii) [Shift] + right-click and drag to move the drawing, 
(iv) [Ctrl] + right-click and drag to rotate the drawing. 
  
The window displays the two merged projects in one view. 
Moreover, the entity currently selected in the merge window (see below) is highlighted in this 
window. 

Property window 
This window is linked to the Merge window. If a particular entity is selected in the Merge window, 
then the corresponding properties are shown in the Property window. This is especially useful 
when the user has to track changes made in the two variants of the project. 

Merge window 
This window lists all the entities that somehow do not coincide in the two projects that are being 
merged. 
Added, deleted and changed entities are shown here. The user may select which changes are to 
be accepted and which ones are to be ignored. 
Individual groups (new, deleted, merged entities) will now be described in more details. 

New entities 
Accepting the group 
By default, the check box at this item is selected (ticked). It means that new entities (as a group) 
will be accepted in the final merged project. If you deselect this check box, no new entities will be 
considered by the update function at all. 
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Specifying the colour of the group 
You may adjust the colour for the new entities. Simply click on the coloured box on the right-
hand side of the "New entities" line and then select the required colour. 
Accepting individual items from the group 
You may select which particular entity (or sub-group) from the "New entities" group should be 
accepted and which one should be declined. Just mark (tick) or unmark (untick) the appropriate 
item. Please note that once you put cursor (click) on a specific item, its properties are shown in 
the middle pane (property window) and the entity itself is highlighted in the preview window. 
Some items may be "grouped" in sub-groups such as load cases in the picture below. This 
enables you to decline (if required) the whole subgroup by unmarking the corresponding sub-
group check box. 
Example: 

 

Deleted entities 
This is analogous to "New entities" described above. 
Example: 

 

Changes (Merged entities) 
This part of the merge window lists all the entities that have different properties in the two 
compared projects. The list always contains the "original" and the "merged" entity. The 
properties of both are shown in the property window (one by one – not together). If you select 
(tick) a particular listed item, the changes made in the merged (second) project will be accepted. 
If you do not select (unmark) a particular listed item, the original (the first project) will be 
preserved. 
Example: 
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Note: The Update function can process geometric entities, load cases, loads, supports, hinges, etc. 
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Allplan 

Allplan 
The exchange of data between Allplan and Scia Engineer can be realised in several ways. First, 
standard export and import routines can be applied. Second, direct interlink of the two programs 
can be used. 
The first approach uses standard Scia Engineer project files. Allplan is capable of both saving 
the project into this format and reading the project from this format. The second approach leads 
to very fast connection – Scia Engineer is opened directly from within the Allplan environment 
and the changes made in one program are automatically taken into account in the second 
program. For example, the following scenario is possible (the aim of this particular example is to 
give you the idea of what is possible, not to present the most effective style of work, even though 
it may even the case for certain situations and types of structures): 
1. The project is started in Allplan. Some Scia Engineer steel templates are inserted into the 

model. 
2. Scia Engineer is opened and one or two 1D members in the model are modified (moved, 

changed cross-section, etc.). 
3. The model is sent back to Allplan and a new Scia Engineer steel template is added. 
4. Scia Engineer is opened again and a part of the model is removed. 
5. The model is sent back to Allplan and the model is completed. 

  

Note: The direct communication between the two programs has inevitably some limitations. The user 
must decide which type of entities will be used: either Allplan architectural elements or Scia Engineer 
steel templates. If this prerequisite is satisfied, the full roundtrip between the two programs is fully 
functioning. On the other hand, if both the above-mentioned types are used in one project, the direct and 
complete exchange of the data between the two programs is not possible. 

  
The following list summarises all Allplan data-exchange functions: 
 Importing SCIA ESA data, 
 Update from ESA file, 
 Exporting SCIA ESA data, 
 Save to ESA file, 
 Edit in Modeller, 
 Calculate ESA. 

Allplan - Importing SCIA ESA data 
Allplan does not create a new project but adds the imported data to the existing currently opened 
model. 
The import function requires that Scia Engineer is installed on the computer where Allplan is run 
– a demo-version is sufficient. 
  

The procedure to import .esa file to Allplan 
1. Start function Create > Interfaces > Importing SCIA ESA data. 
2. Browse for the file to-be-imported. 
3. A dialogue with import parameters is opened on the screen. 
4. Fill in the required parameters (see below). 
5. Confirm the settings to proceed with the import. 
6. If the option Make special adjustment was selected for the View parameters, the View 

parameters dialogue opens on the screen. In that case, make the necessary settings and 
end the import. 

7. The import is done. 
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Import parameters dialogue 

Colour 

Use colours from ESA 
project 

The imported entities are assigned colours as 
they were adjusted in Scia Engineer. 

Colour from Allplan The colours are taken from the settings made 
in Allplan. 

  

View parameters 

Use adjustment from 
ESA project 

The view parameters are taken exactly as 
they were set in Scia Engineer. 

Make special 
adjustment 

The user may adjust the view parameters 
manually during the import procedure. 

Precise member 
surface 

If ON, the outline of cross-sections is drawn 
with utmost precision. 

  

3D geometry 

One volume If ON, the whole imported structure is made a 
single object in Allplan. 

  

Allplan element 

BIE Macro If ON, the imported data are stored as Allplan 
BIE macros. 

Structural element If ON, the the imported data are stored as 
Allplan structural elements (Konstruktive 
Fertigteil). 

The imported data cannot be edited by Scia 
Engineer editing functions integrated in 
Allplan. The editing can only be done through 
standard Allplan functions. 

Allplan - Update from ESA file 
This function reads a Scia Engineer  data file and adds its contents to the currently opened 
project in Allplan. 
The function requires that iScia Engineer is installed on the computer where Allplan is run – a 
demo-version is sufficient. 
The imported data update the existing members in the currently open project (this, however, 
applies to steel templates only). 

The procedure to update data in Allplan from .esa file 
1. Start function Create > Add-On modules > Steel/Concrete Construction > Update from 

ESA file. 
2. Browse for the file to-be-imported. 
3. A dialogue with import parameters is opened on the screen. 
4. Fill in the required parameters (see Importing SCIA ESA data). 
5. Confirm the settings to proceed with the import. 
6. If the option Make special adjustment was selected for the View parameters, the View 

parameters dialogue opens on the screen. In that case, make the necessary settings and 
end the import. 

7. The update is done. 
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Allplan - Exporting SCIA ESA data 
This function exports the whole project created or edited in Allplan into Scia Engineer data file. 
The export function requires that Scia Engineer is installed on the computer where Allplan is run 
– a demo-version is sufficient. 

The procedure to export data into .esa file from Allplan 
1. Start function Create > Interfaces > Exporting SCIA ESA data. 
2. Browse for the required folder and specify the file name. 
3. Export is done. 

Allplan - Save to ESA file 
This function saves the project created or edited in Allplan into Scia Engineer  data file. 
The function requires that Scia Engineer is installed on the computer where Allplan is run – a 
demo-version is sufficient. 
The function enables the user to save either the whole project or just a selected part of it into the 
Scia Engineer data file. 

The procedure to save data into .esa file from Allplan 
1. Start function Create > Add-On modules > Steel/Concrete Construction > Save to ESA 

file. 
2. Select the entities to be saved or save the whole project. 
3. Browse for the required folder and specify the file name. 
4. Save-operation is complete. 

Allplan - Edit in Modeller 
If you are creating a model of a structure composed of Scia Engineer steel templates, you may 
freely swap between Allplan and Scia Engineer and work in both programs almost at the same 
time. The scenario (given also in the introductory chapter) can be like this: 
1. The project is started in Allplan. Some Scia Engineer steel templates are inserted into the 

model. 
2. Scia Engineer is opened and one or two 1D members in the model are modified (moved, 

changed cross-section, etc.). 
3. The model is sent back to Allplan and a new Scia Engineer steel template added. 
4. And so on and so forth. 

  
Any change of the model made in either program is automatically reflected in the other program. 
  

The procedure to perform this combined editing 
1. In Allplan start with the model (i.e. insert some Scia Engineer steel templates). 
2. Start function Modify > Add-on Modules > Steel/Concrete Construction > Edit in 

Modeller. 
3. Select the entities to be sent to Scia Engineer Modeller. 
4. Scia Engineer is opened and the Roundtrip dialogue appears in the screen.. 
5. Do whatever is needed. 
6. Call function (in Scia Engineer ) File > Close. 
7. A small Save-Cancel dialogue opens on the screen. 
8. Select the option that saves the changes. 
9. You are back in Allplan. 

  
Note: Please note that Allplan function Create > Add-on Modules > Steel/Concrete 
Construction > Start Modeller starts the Scia Engineer Modeller and opens an empty 
project in it. It does not transfer the data from your current Allplan project. 

  

Note: It is not recommended to combine in one project Allplan architectural elements and Scia Engineer 
steel templates. If both the types are used in one project, the direct and complete exchange of the data 
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between the two programs is not possible. On the other hand, separate import and export functions are 
still fully applicable. 

Allplan - Calculate ESA 
If you are creating a model of a structure composed of architectural elements, you may freely 
swap between Allplan and Scia Engineer and work in both programs almost at the same time. 
The general scenario is the same like for Editing in Modeller. However, you may decide which 
change of the model is taken into account. 
  

The procedure to perform this combined editing 
1. In Allplan start with the model. 
2. Start function Modify > Add-on Modules > Steel/Concrete Construction > Calculate 

ESA. 
3. Select the entities to be sent to Scia Engineer. 
4. Scia Engineer is opened. 
5. Do whatever you need. 
6. Call function (in Scia Engineer) File > Close. 
7. A small Save-Cancel dialogue opens on the screen. 
8. Select the option that saves the changes. 
9. You are back in Allplan. 

  
The important feature comes into play when you are swapping to Scia Engineer for the second 
(third, fourth, etc.) time. Scia Engineer can recognise that you have been already editing the 
same project in it and (in order to help you tracing the changes made in Allplan) opens the 
dialogue that compares two variants: (i) the data that are currently sent from Allplan to Scia 
Engineer and (ii) the data that were saved the last time you were working in Scia Engineer. 
A special designed dialogue guides you through the changes and allows you to decide which 
changes are to be approved and which ones are to be discarded. This is the Scia Engineer 
update dialogue that is described in a separate chapter. 
  

Note: It is not recommended to combine in one project Allplan architectural elements and Scia Engineer 
steel templates. If both the types are used in one project, the direct and complete exchange of the data 
between the two programs is not possible. On the other hand, separate import and export functions are 
still fully applicable. 
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XML 

XML 
Scia Engineer allows for the exchange of data with third-party applications through the popular 
and powerful XML format. Moreover, XML format can be used to develop tailor-made 
applications that use Scia Engineer as a "hidden" engine working on the background and 
performing calculations of company-specific problems. 
  

Note: The aim of this text is to present the principles of XML interface. The full explanation of all features 
and all capabilities of XML import/export/update would occupy dozens and maybe even hundreds of 
pages and exceeds the extent and scope of this text. Users who are interested in the application of XML 
interface in their practice are kindly asked to contact the help-desk of SCIA Company. SCIA specialists 
will be happy to give concrete piece of advice that could help solve the particular problem of your 
company. 

XML import 

The procedure to import data from XML file 
1. Start menu function File > Import > XML file. 
2. Browse for the required .xml file. 
3. Confirm the selection of the file. 
4. If required by the import procedure, specify the national standard to be used. 
5. Finish the import. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

XML export 

The procedure to export data into XML file 
1. Use the tree menu to start function Tools > XML. 
2. XML file editor is opened on the screen. Before it is opened, the program may ask you to 

select the default XML document template. You may select one or just close the dialogue 
without choosing anything. If you want to export the whole structure into a XML file, it is 
convenient to select the default.TDX template. 

3. In the XML file editor define the structure of the XML document. 
4. Use icon Export on the toolbar to export the created document into a XML file. 
5. Close the XML file editor. 

  

Note: Please remember that the order of Scia Engineer entities stored in the exported XML file must 
guarantee that all the references are made to entities stored earlier in the file. It means, for example, that 
materials must come before cross-sections, cross-sections and nodes must come before 1D members, 
load cases must come before load case combinations, etc. 

XML file editor 
The XML file editor is very similar to the Document of Scia Engineer. The principle is that the 
user defines tables describing individual entities of the Scia Engineer projects and there order. 
This table-form can be easily previewed (it is in fact identical to the standard Scia Engineer 
document). When ready, the final XML file contents can be transformed into the real XML format 
through the Export function. 
  
The dialogue contains the following parts: 

XML document Selects the required XML document if more 
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selection box than one document has been created. 
  

button to open the 
XML document 
manager 

Opens the XML document manager where 
you can create new documents or delete the 
existing ones. It is a standard Scia Engineer 
database manager. 
  

XML file contents 
window 

This window shows the contents and 
structure of the currently edited document. 
This is analogous to the document tree 
window. 
  

property window Displays parameters related to currently 
selected item in the XML file contents 
window. This is analogous to the document 
property window. 
  

icon toolbar Contains buttons (icons) that perform various 
actions. The toolbar is identical with the 
Document window toolbar. 
  

control buttons There are two control buttons: 

[New] – adds a new item to the XML file 
contents window. 

[Close] – closes the XML file editor. 
  

action button There is just one action button – it refreshes 
the preview window of the XML file editor. 
  

preview window Displays the currently edited XML file in table-
form. 
  

XML update 

The procedure to update the project through XML file 
1. Open in Scia Engineer the project to-be-updated. 
2. Call function File > Update > XML file. 
3. Browse for the file to-be-merged. 
4. Confirm the selection of the file. 
5. The project in Scia Engineer is updated by the data read from the file. 

  

Note: For more information on the update function read chapter XML update example. 

XML update example 
Let us have a project named Cantilever.esa with a simple cantilever beam of a circular cross-
section. 
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The dimensions of the cross-section are defined through two parameters: Diameter and 
Thickness. 

 
  
Both the parameters are of type Cross-section length (Css length) and their initial values are 200 
mm and 5 mm. 

 
  
Now we have to open the XML file editor (tree menu function Tools > XML). 
There we have to create a new "XML document" containing the table of defined parameters. 
To do so, we add the table Libraries > Parameters. 



Export, Import, Roundtrip 

14 

 
The inserted table looks like this: 

 
  
The created XML document must be exported into XML file. This can be achieved through 
function Export (available on the toolbar of the preview window in the XML file editor). 
The generated XML file (named CantileverParameters.xml) looks like: 

XML file Comment 
<?xml version="1.0" encoding="UTF-8" 
standalone="yes" ?> 
- <project xmlns="http://www.scia.cz"> 
  <def uri="CantileverParameters.xml.def" /> 
- <container id="{5C62EA11-86D4-11D4-B3AB-
00104BC3B531}" t="EP_Parameters.EP_Param.1"> 
- <table id="B4DDEC1E-5869-4B8C-8B4B-
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1A8C07B76699" t="EP_Parameters.EP_Param.1"> 
- <h> 
  <h0 t="Name" /> 
  <h1 t="UniqueID" /> 
  <h2 t="Type" /> 
  <h3 t="Evaluation" /> 
  <h4 t="Use range" /> 
  <h5 t="Value" /> 
</h> 
- <obj id="1" nm="Diameter"> 
  <p0 v="Diameter" /> 
  <p1 v="{FDD9298F-1A51-406B-9887-
8C9302981A47}" /> 
  <p2 v="11" t="Css length" /> 
  <p3 v="0" t="Value" /> 
  <p4 v="0" /> 
- <p5 t=""> 
- <h> 
  <h0 t="Real" /> 
</h> 
- <row id="0"> 
  <p0 v="0.2" /> 
</row> 
</p5> 
</obj> 

Parameter Diameter 
  
  
  
  
  
  
  
  
  
  
value = 0.2 m 

- <obj id="2" nm="Thicknes"> 
  <p0 v="Thicknes" /> 
  <p1 v="{9E8E662D-4B12-43EE-8A56-
A33948D079A1}" /> 
  <p2 v="11" t="Css length" /> 
  <p3 v="0" t="Value" /> 
  <p4 v="0" /> 
- <p5 t=""> 
- <h> 
  <h0 t="Real" /> 
</h> 
- <row id="0"> 
  <p0 v="0.005" /> 
</row> 
</p5> 
</obj> 

Parameter 
Thickness 
  
  
  
  
  
  
  
  
  
  
value = 0.005 m 

</table> 
</container> 
</project> 

  

  
We will not explain the meaning of every single line of the XML document. The example above 
demonstrates the structure of the XML file and shows the way the two parameters from our 
example are stored. 
  

Note: When the export function is invoked, the XML file editor generates in fact two files: XML file and the 
corresponding definition file (DEF file). For example, if the name of the XML file is MyFile.XML, the name 
of the definition file is MyFile.xml.DEF. Briefly said, the definition file contains the definition of all the 
characteristics that are referred to in the XML file. 
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Manual XML update 
And now, we may demonstrate the principle of the XML update function. Let us assume that we 
have a tool that can read and modify the XML file. Using this tool we can change the value of the 
parameters in the XML file. Let us assume that the value of the Diameter was changed to 0.8 m. 
  

Note: Later we will show how exactly this can be done. For the time being, let us take it for granted that 
the tool changed the XML file and modified parameter Diameter. 

  
Let us go back to Scia Engineer where our original project is still open. Call function File > 
Update > XML file and browse for our modified file. 
The program updates the data of the project (in our example - the values of the parameters) and 
we can see the result on the screen. The tube has increased its diameter four times. 

 
  

Automatic XML update 
Now, let us return to the idea of an external tool that is capable of modifying the XML file. 
Probably every engineering office uses a kind of spreadsheet processor such as MS EXCEL. 
Taking into account the fact that the Microsoft’s product is probably the most widespread tool 
available in the market, we will use it in our example. 

List of operations carried out by the EXCEL application 
The EXCEL "application" will do the following operations: 
A. it will take our input of the diameter and thickness of the cross-section, 
B. it will generate the appropriate XML file, 
C. it will open the Scia Engineer project with the cantilever in question, 
D. it will update the cross-section using the values from the generated XML file, 
E. it will perform the calculation, 
F. it will generate output document containing the calculated deformation of the cantilever, 
G. it will import this document into the EXCEL sheet, 
H. it will show the vertical displacement of the free end of the cantilever directly in the EXCEL 

sheet. 
  
Note: The EXCEL application could naturally display also other results. In the interests of 
brevity, clarity, and comprehension, we will deal in our example just this single result 
value. 

  
We will prepare a VBA script (run from a XLS sheet) that will perform all the described 
operations. Scia Engineer as a calculation engine will be running "somewhere" on the 
background. The user won’t even spot it on the screen and will be able to think that the EXCEL 
sheet itself does everything. 
  
To start with, we have to pre-prepare something in Scia Engineer. 
First, we have to generate the .XML "template" file and the corresponding .DEF file. This was 
already done earlier in our example and we can simply take the produced .XML file. Unless we 
decide to use different folder (different then Scia Engineer project folder) for our EXCEL 
application, we do not have to bother about the .DEF file. It will be in the right place by default. 
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Second, we have to create a document in our Scia Engineer project. The document must contain 
the table with calculated nodal displacements. The project must be then saved. 

 
  
Let us now start MS EXCEL, create a new document and define two sheets. Let us name them 
"Table" and "XML". The first one (Table) will be our "User interface", i.e. it will be the sheet that 
will be used by the user. The other one (XML) will be used as an auxiliary sheet to hold the 
contents of the XML file we have to generate (Please note that there are other possibilities (in 
terms of programming techniques) to store the contents of the XML-file-to-be-generated that 
may prove more efficient in terms of speed for large projects with large XML files. Our example 
is quite a simple one and we may afford to store the data in the sheet). 
  
Design the "Table" sheet as in the figure: 

 
You can see that the sheet takes two values as input (the blue cells B17 and B18) and displays 
one value as output (the yellow cell B25). The sheet contains a simple illustrative picture 
(scanned from Scia Engineer) and a button that starts all the operations listed above. 
  
The second sheet holds the contents of the XML file that is needed for the XML update 
functionality of Scia Engineer. 
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The XML content is in the second column (B). The first column (A) is almost(!) empty. It just 
contains letters "d" and "t" in rows where the values of the diameter and thickness are stored. 
This arrangement was selected with regard to the algorithm programmed in our sample VBA 
script. The simplest way to fill in this "XML" sheet is to open the exported 
CantileverParameters.xml file in a simple text editor, remove all blank lines and copy+paste it 
to the second column of the "XML" sheet. The blank lines have been removed to allow for a very 
simple VBA script. 
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Now we have to define the procedure that is triggered by clicking the button [Recalculate] from 
the "Table" sheet. The procedure may look like: 
  
Private Sub Recalculate_Click() 
' Open XML file for writing 
Dim fs, f 
Set fs = CreateObject("Scripting.FileSystemObject") 
Set f = fs.CreateTextFile("E:\SCIA\EsaData\CantileverParameters.xml", 
True) 
' we assume that the data are stored in folder E:\SCIA\EsaData 
' Generate XML file using the two input values 
Dim SomethingToWrite As Boolean 
SomethingToWrite = True 
Dim mystring As String 
Dim i As Integer 
i = 1 
Do 
mystring = Worksheets("XML").Cells(i, 2).Value 
If mystring <> "" Then 
If Worksheets("XML").Cells(i, 1).Value = "d" Then 
' this line stores the value of the diameter 
mystring = " <p0 v=""" & Str(Worksheets("Table").Cells(17, 2).Value / 
1000) & """/>" 
End If 
If Worksheets("XML").Cells(i, 1).Value = "t" Then 
' this line stores the value of the thickness 
mystring = " <p0 v=""" & Str(Worksheets("Table").Cells(18, 2).Value / 
1000) & """/>" 
End If 
f.WriteLine (mystring) 
i = i + 1 
Else 
SomethingToWrite = False 
End If 
Loop While SomethingToWrite = True 
f.Close 
' Invoke the update of the project + 
' Run the calculation + 
' Export the document into XLS file 
Shell ("D:\ESA\Esa_XML.exe LIN E:\SCIA\EsaData\Cantilever.esa 
E:\EsaData\SCIA\CantileverParameters.xml /tHTML 
/oE:\SCIA\EsaData\CantileverParameters.xls") 
'Assumptions: 
' Scia Engineer installed in folder D:\ESA 
' project file stored in fodler E:\SCIA\EsaData 
' XML file generated to folder E:\SCIA\EsaData 
' Note: 
' File Esa_XML.exe is an integral part of Scia Engineer installation 
' Parameters of "SHELL" command 
' D:\ESA\Esa_XML.exe = location of Esa_XML.exe 
' LIN = linear calculation 
' E:\SCIA\EsaData\Cantilever.esa = original project file 
' E:\EsaData\SCIA\CantileverParameters.xml = XML file for the update 
function 
' /tHTML /oE:\SCIA\EsaData\CantileverParameters.xls = export the 
document stored inside the project file as HTML file with location and 
name E:\SCIA\EsaData\CantileverParameters.xls 
  
Application.Wait (Now + TimeValue("0:00:15")) 
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' wait in order to guarantee that Scia Engineer completes the calculation 
before the control of the operation is returned to the VBA script 
' Read result into XLS sheet + 
' Insert the result value into the appropriate cell of the "Table" 
sheet 
Dim myresult As Variant 
Workbooks.Open Filename:="E:\SCIA\EsaData\CantileverParameters.xls" 
myresult = Sheets("CantileverParameters").Cells(8, 5).Value 
' Cell (8,5) of the "document file" contains the required vertical 
displacement 
' to find out this, you have to open the generated XLS file manually 
(only once) and note down the cell coordinates 
Workbooks("CantileverParameters.xls").Close 
Worksheets("Table").Cells(25, 2).Value = myresult 
  
End Sub 
  
Now we can start playing with the EXCEL application. Just type the two input parameters, click 
button [Recalculate] and (after a few seconds) you can see the vertical displacement shown in 
the "Deflection" cell. 
  

Note: Please, consider this chapter to be only a brief introduction to the XML update and contact SCIA 
support team for more information and/or guidance. 
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Graphical format 

Graphic format 
Export 

Scia Engineer enables the user to export the graphical representation of the project into a 
graphical file. This type of export usually work with the data that are displayed in the graphical 
window of Scia Engineer at the moment the export procedure is started. Formats VRML, DXF 
and DWG are exceptions as they allow the user to export the whole project and even specify 
special export parameters. 
The procedure to export data into a graphical file is given in a separate topic. 
Various graphical formats are available in Scia Engineer: 

BMP Standard Windows bitmap 
  

VRML Virtual Reality Modeling Language (V-R-M-L) 

A standardised language used to transmit 
information about 3D images over the web 
(WWW). Since the image is built up on the 
local computer VRML information 
transmission is more efficient than sending 
the actual image. 

For more information on this format read 
bellow the table. 
  

EP3 Internal graphical format of Scia Engineer 
  

EMF Extended (Enhanced) Windows Metafile 
Format 
  

WMF Windows Meta File (W-M-F) 

A graphic file format used by Microsoft to 
transfer graphics between Windows 
applications. Both bitmap and vector graphics 
are supported by WMF. A variation on WMF 
is and extended version known as EMF. 
  

3D DWG AutoCAD R14, 
2000 

3D DWG AutoCAD R11 
– 2006 

DWG (AutoCAD) format. 
  

2D DWG AutoCAD R14, 
2000 

Please note that only versions R14 and 2000 
are supported. 
  

3D DXF AutoCAD R14, 
2000 

3D DXF AutoCAD R11 - 
2006 

DXF (e.g. AutoCAD) format. 

2D DXF AutoCAD R14, 
2000 

Please note that only versions R14 and 2000 
are supported. 
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Import 
For special graphical formats DXF, DWG, VRML also the import procedure is supported in Scia 
Engineer. This is described in separate topics. 
  

VRML 
This format represents a powerful tool enabling the users to publish virtual objects via VRML and 
also import them into Scia Engineer. Vast number of CAD software applications support the 
export of VRML files (AllPlan, AutoCAD, CEA Systems, etc.). The import of VRML files is done 
the same way as for DXF and DWG files. For example, the imported data can be used as a 3D 
grid or as a background. They are not taken into account for the analysis. 
The virtual objects can be used: 

 for the visualization architectural elements sent from 3rd parties, 
 as a drawing tool – snapping functionality, 
 for pro-active viewing of changes and consequences due to optimisation or structural 

adaptations (e.g. deformations), 
 for visualization of the analysed structure in its environment, 
 for the visualization of piping generated by Plant design applications, 
 etc. 

The virtual objects can afterwards be exported again to VRML format file for 3D publishing of the 
structure including the results of analysis. 
Examples: 
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Graphic format export 

The procedure to export data into a graphical file 
1. Start menu function File > Export > Graphic format. 
2. Select the format of the graphical file. 
3. Specify the required output folder. 
4. Type the name of the file. 
5. Complete the export. 
6. Note: A special dialogue opens for DWG and DXF formats in which you can specify some 

export parameters. 
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Export and import of DXF, DWG and VRML 

Export from the graphical window 

The procedure to export DXF / DWG file from graphical window 
1) Use one of the following functions: 

a) File > Export > Graphic format. 
b) Righ-mouse-button-pop-up menu > Save picture to file. 

2) It is possible to choose from the following formats: 
a) 3D DWG AutoCAD R11 - 2007 (*.dwg) 
b) 2D DWG AutoCAD R14, 2000 (*.dwg) 
c) 3D DXF AutoCAD R11 - 2007 (*.dxf) 
d) 2D DXF AutoCAD R14, 2000 (*.dxf) 
(Note: this list is only informative, available options may vary from version to version). 

3) When you enter the file name and path, confirm with button [Save]. Another dialogue is opened 
on the screen where you can define some details of the export. 

   

 
4) Adjust the properties (see below) and confirm with [OK]. 

  

Export properties 

File properties group name 

Name Pathname of the exported file. 

Text code page Windows ANSI or Eastern Europe coding can be 
adjusted. 

Advanced group name 

Scale Scale for text and graphical symbols that will be in 
the exported drawing. 

Structure 
surface always 

If ON, the individual members will be exported 
including the surface. 
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as 3D solid 

  

Note: 2D DXF and 2D DWG export does not support option Structure surface always as 3D solid, which is 
quite understandable. 

  
Note: See also Saving the picture into an external file. 

  

Export of FE mesh to AutoCAD as 3D-face 
It is possible to export the generated finite element mesh as 3D-face to both DWG and DXF file. 
To do so, the mesh must be displayed in Scia Engineer . There is no other action required. If the 
FE mesh is displayed in the graphical window at the moment the export to DWG/DXF is started, 
the mesh is automatically exported as a separate layer called "3D-FACE". By default, this layer 
is hidden. In order to see it in AutoCAD, the layer must be switched ON manually. 
  
   

Export from the picture gallery 

The pictures from the Picture gallery may be exported into DWG or DXF file in the same way as 
from the graphical window. 

The procedure to export DXF / DWG file from the Picture gallery 
1. Open the Picture gallery. 
2. Select the picture to be exported. 
3. Click icon Save picture to file. 
4. Input the file name and path. 
5. Adjust file parameters (see Export from graphical window). 
6. Confirm with [OK]. 

   

Export from the Paperspace gallery 

The pictures from the paperspace may be exported into DWG or DXF file in the similar way as 
from the graphical window. 

The procedure to export DXF / DWG file from the Paperspace gallery 
1. Open the Paperspace gallery manager. 
2. Select the picture to be exported. 
3. Click icon Save picture to file. 
4. Input the file name and path. 
5. Adjust file parameters (see Export from graphical window). 
6. Confirm with [OK]. 

  

Note: The export from Paperpace gallery is limited to 2D DWG and 2D DXF format. 

  

Import into the graphical window 

Procedure for the import of DWG, DXF or VRML file into the graphical window 
1. Start the tree menu function Structure > Drawing tools > Import DWG, DXF, VRML 97 

file. 
2. The Open file dialogue is opened on the screen. 
3. Browse for the file and confirm. 
4. A special import dialogue is opened on the screen. 
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5. Adjust the required parameters in dialogue and perform the import itself – see below. 

  

Layers 
This list box contains the layers that were defined in the original DWG/DXF file. Only selected 
layers are shown in the preview window of the Import dialogue. 

Entity types 
This list contains available entity types. Only selected types are shown in the preview window of 
the Import dialogue. 

Selection mode 

Lines The drawing is read as lines. The lines may be assigned to 
particular layers. On pressing the "Import" button, the property 
dialogue is opened and you may specify the required 
parameters. 



Graphical format 

27 

 
  

Beams The drawing is read as 1D members. On pressing the "Import" 
button, the property dialogue is opened and you may specify 
the required parameters. 

 
  

Slabs The drawing is read as slabs. On pressing the "Import" button, 
the property dialogue is opened and you may specify the 
required parameters. 
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Solids The drawing is read as solid objects that are displayed together 
with the analysed structure but are neglected during the 
calculation. 

  

Note: When slabs are to be imported, it is required that the closed polygon was created already in the file 
that will be imported. 

Scale 
The scale for the import. It may be necessary when the drawing is not in SI units. The item 
provides for the transformation from "imaginary" units of the DWG/DXF file and metres (used in 
Scia Engineer as the basic unit). 

Note: If the scale is set to 1 (one), Scia Engineer assumes the data to be stored in metres. 

Insertion point 
The user can define the insertion point: 

Centre 
The centre of the model in the imported file is selected as the insertion point (where the cursor 
is) and by this point the user can place the imported model into the graphical window. 
The "centre" is the centre of a bounding rectangle circumscribed around the imported model. 

Original 
The original insertion point of the imported model is selected as the insertion point (where the 
cursor is) and by this point the user can place the imported model into the graphical window. 

Origin in 0,0,0 
The origin of the coordinate system of the imported file is placed into the origin (0,0,0) of the 
coordinate system in Scia Engineer. 
  

Sizes 
This is an informative item, which shows the dimensions calculated from the input scale. 
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Tools (Connect curves, Connect solids, Solids smoothing) 
These tools allow the user to slightly "modify" the DWG/DXF file before it is imported into Scia 
Engineer. 

Connect curves 
This tool connects individual lines from the imported file to a polyline. This may be useful to 
reduce the total number of lines in the imported model. It may also simplify the manipulation with 
the imported model. 
The procedure: 
1. Select Connect curves. 
2. Click [Start]. 
3. Select the lines to be connected together. 
4. Press [Run]. 
5. Repeat as many times as required. 
6. Click [End] 

Connect solids 
This tool connects individual solids from the imported file. Similarly to connecting of lines (above) 
it can reduce the total number of solids in the imported model and simplify the manipulation with 
the imported model. 
The procedure: 
1. Select Connect solids. 
2. Click [Start]. 
3. Select the solids to be connected together. 
4. Press [Run]. 
5. Repeat as many times as required. 
6. Click [End] 

Solids smoothing 
This tool allows the user to "improve" the imported solid by smoothing the surface, which means 
reducing the number of edges. This is especially useful if the imported solid was not modelled in 
an ideal way and contains redundant edges that are not important for the description of the 
proper shape of the solid. 
The procedure: 
1. Select Solids smoothing. 
2. Click [Start]. 
3. Select the part of the imported solid that is to be smoothened. Alternatively, use the window 

selection to select everything (click in the top left corner of the preview window and drag the 
mouse to the bottom right corner, then release the button). 

4. Press [Run] and specify the smoothness parameter: 0 = the minimum possible number of 
edges will be used to represent the shape of the imported solid (in some situations it may 
degrade the shape - e,g, a cube may get rounded corners). 60 = all the edges in the 
imported model will be preserved. Usually, a few (trial and error) rounds are necessary to 
find the best value for a particular model - there is no general rule to say which value is the 
best. 

5. Repeat as many times as required. 
6. Click [End] 

  

Number of vertexes on polyline substituting imported spline 
Some CAD applications use a definition of a spline curve that is different from the one used in 
Scia Engineer. Such splines are imported as polylines. This parameter specifies the number of 
vertexes on the substituting polyline. 

Preview window 
The view in the preview can be adjusted using the standard Scia Engineer mouse+key controls 
(shifted, rotated, zoomed in/out). 
Three check boxes are related to the preview window: 

OpenGL in preview window 
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If ON, the parts of the model hidden behind other parts of the model are not drawn. Of OFF, the 
visibility is not considered and everything is displayed (which means faster response but may 
cause in some confusions). 

OpenGL selection 
If ON, the cursor selects the "visible" (the top most) part of the model (if two entities re located 
over each other). If OFF, the standard selection mode is active. 

Show all objects 
Some objects from the DWG/DXF that has no equivalent in Scia Engineer (e.g. text) cannot be 
imported to Scia Engineer. This objects are not shown in the Preview window. If you want to 
see them, select this option. 

 
  

Note: Sometimes it may be convenient to import the drawing as lines and only later (i.e. in Scia Engineer 
graphical environment) transform the lines to 1D members using function Drawing a member in mode 

Select line ( ). 

  

Import selected / Import all 
This button start the import itself. Either entities selected in the Preview window or All entities 
from the Preview window are imported as lines or 1D members or slabs (depending on the 
adjustment of other import parameters). When the button is pressed, the property dialogue for 
lines or 1D members or slabs (depending on the adjustment of other import parameters) is 
opened on the screen and you may set the required properties. 
   

Import into the Paperspace gallery 

DWG, DXF and VRML files can be imported as a picture or as a drawing. 

Importing a picture 
This function imports the DWG, DXF and VRML file as a "standalone" picture. The picture can 
be placed anywhere to the drawing, resized, moved, etc. 

Procedure to insert a picture from DWG or DXF file 
1. Open the Paperspace gallery. 
2. Open or create a drawing. 
3. Start function Insert picture > Insert picture from DWG or DXF file. 
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4. Two file types are available: 
a. AutoCAD R12, R13, R14, 2000 (*.dxf) 
b. AutoCAD R12, R13, R14, 2000 (*.dwg) 

2. Select the file and open it. 
3. Import properties dialogue is opened on the screen. 

 
5. Adjust the required properties (see below) and confirm. 
6. Use the mouse to position the picture and the left mouse button to drag the size of the 

picture on the drawing. 

Procedure to insert a picture from VRML file 
1. Open the Paperspace gallery. 
2. Open or create a drawing. 
3. Start function Insert picture > Insert picture from VRML file. 
4. Select the file and open it. 
5. Use the mouse to position the picture and the left mouse button to drag the size of the 

picture on the drawing. 

Layers 
This list box contains the layers that were defined in the original DWG/DXF file. Only selected 
layers are shown in the preview window of the Import dialogue. 

Entity types 
This list contains available entity types. Only selected types are shown in the preview window of 
the Import dialogue. 
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Line styles 
This window contains all the line styles that are used in the imported file. 

Style 
This box offer the styles of a line that can be used in the program. They can be assigned to 
individual line types from the original file. 

Default line thickness 
Lines in DWG/DXF files may have either specific thickness or default thickness. In order to avoid 
using unknown thickness lines, the import dialogue enables you to define the numerical value for 
the default thickness. 

Optimize scene 
If ON, the lines with the same properties are joined together and drawn at the same time. 

Text scale 
Specifies the scale of the text. 

Preview, view direction 
The view in the preview can be adjusted using the standard Scia Engineer mouse+key controls 
(shifted, rotated, zoomed in/out). 
  

Importing a drawing 
This function imports the DWG/DXF file as a drawing, i.e. it is added to the current drawing as a 
new part of it. The "size" of the imported drawing can be defined through parameter Scale. 

Procedure to insert a drawing from DWG or DXF file 
1. Open the Paperspace gallery. 
2. Open or create a drawing. 
3. Start function Insert picture > Insert drawing from DWG or DXF file. 
4. Two file types are available: 

a. AutoCAD R12, R13, R14, 2000 (*.dxf) 
b. AutoCAD R12, R13, R14, 2000 (*.dwg) 

2. Select the file and open it. 
3. Import properties dialogue is opened on the screen. 
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5. Adjust the required properties (see below) and confirm. 
6. Use the mouse to position the imported drawing to the current drawing. 

Layers 
This list box contains the layers that were defined in the original DWG/DXF file. Only selected 
layers are shown in the preview window of the Import dialogue. 

Entity types 
This list contains available entity types. Only selected types are shown in the preview window of 
the Import dialogue. 

Line styles 
This window contains all the line styles that are used in the imported file. 

Style 
This box offer the styles of a line that can be used in the program. They can be assigned to 
individual line types from the original file. 

Default line thickness 
Lines in DWG/DXF files may have either specific thickness or default thickness. In order to avoid 
using unknown thickness lines, the import dialogue enables you to define the numerical value for 
the default thickness. 
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Transformation – Insertion point 
The imported drawing can be placed to a specified place in the current drawing (e.g. bottom left 
corner, centre, etc.). The meaning of individual options is clear from the name of the option. 
  

Note: When option By mouse two points is selected, the input box Scale is hidden. The two points define 
the size of the imported drawing and the Scale parameter becomes redundant. 

  

Scale 
Specifies the scale for the imported drawing. 

Text scale 
Specifies the scale of the text. 

Preview, view direction 
The view in the preview can be adjusted using the standard Scia Engineer mouse+key controls 
(shifted, rotated, zoomed in/out). 
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Revit 

Revit 
The Scia Engineer finite element analysis allows for (through the structural CAD model) a direct 
analysis of plates, walls, frames and any kind of mixed structures of Autodesk® Revit® Structure 
2010. 

What can be exported and imported? 

 Geometry (Revit builds an architectural/structural model and converts it into an analysis 
model) - Plates, walls, shells, 1D members, columns, bracings. 

 Supports (Revit footings are converted into rigid supports in Scia Engineer) 
 Loads (Revit inputs loads in Load Cases - these are converted into free loads in Scia 

Engineer). 
 Combinations (combinations are possible but can be ignored in the export to Scia Engineer) 

What are the installation requirements? 
The link works as a Revit’s plug-in, so you must have Revit installed - with or without Scia 
Engineer. 
Scia Engineer user who have also Revit can make modifications in Revit and update them in 
Scia Engineer or vice versa. 

How does it work? 
Revit creates the model and it can be exported to Scia Engineer through function Tools > 
External Tools > Send model to Scia Engineer. There are two possible approaches. 

1. Through a direct export to Scia Engineer. Scia Engineer is opened and the structure is 
visualized. The structure can be sent to Revit again, changed there and again updated to Scia 
Engineer, and over and over again. 

2. Through a simple export to a file. 
  
Scia Engineer checks the geometry, generates the FE mesh and performs the analysis. The 
structure can also be optimized and modified and then updated in Revit: 

1. Function Update from Scia Engineer can be invoked: the structure in Revit is updated with 
the new dimensions. 

2. After updating the user saves the model to a Revit file and that file is read into Revit. 
  
Changes can be traced in Revit: modifications or added members are highlighted; deletions are 
listed. 
For further info read chapters: Revit import, Revit export, Revit update. 

Revit import 

The procedure to import data from Revit file 
1. Start menu function File > Import > Revit file. 
2. Browse for the required .r2s file. 
3. Confirm the selection of the file. 
4. If required by the import procedure, specify the national standard to be used. 
5. Finish the import. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

Revit export 

The procedure to export data into Revit file 
1. Start menu function File > Export > Revit file. 
2. Specify the required output folder. 
3. Type the name of the file. 
4. Complete the export. 
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Revit update 

The procedure to update the project through Revit file 
1. Open in Scia Engineer the project to-be-updated. 
2. Call function File > Update > Revit file. 
3. Browse for the file to-be-merged. 
4. Confirm the selection of the file. 
5. The project in Scia Engineer is updated by the data read from the file. 

  

Sample roundtrip procedure 

Step 1: Autodesk® Revit® Structure 
A 3D model is prepared in Autodesk Revit Structure: 

 
  
Then it is exported to Scia Engineer by the Revit Structure 3 or 4 plug-in, designed by SCIA: 

 

 
  
The export features: 
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Either the complete model or only a selected part can be exported. 
Revit combinations can be exported or ignored. If the latter is the case, new combinations must 
be defined in Scia Engineer. 
The export can be done directly to Scia Engineer, on condition that Scia Engineer is installed on 
the same computer. The plug-in opens Scia Engineer – both applications will be open. 
Modifications done in Scia Engineer can be then sent to Revit. When Revit function Update 
from Scia Engineer is called, the model is accepted in Revit and changes to the model can be 
traced in Revit Structure. 
The export can also be done to an external file. This file with extension *.r2s can be sent to the 
construction partner. This partner is able to open the mode in Scia Engineer and save it again to 
the file with the same extension. 
  
Mapping tables must be defined by the user to link the Revit Structure cross-section list to the 
Scia Engineer cross-section library. The same must be done for the materials defined in Revit 
Structure and for the Revit cross-sections and material families. 
After this primary export, new modifications made in Revit can be re-sent to Scia Engineer. 

Step 2: Scia Engineer - finite elements analysis software 
The model received from Revit Structure can be checked and corrected automatically for 
analytical anomalies and, if required, modified in Scia Engineer for further analysis. 
The received model can contain: 

 Columns, beams 
 Plates 
 Holes 
 Walls 
 Curved slabs 
 Loads & load cases 
 Supports 

  
The structural model is automatically converted into an analysis model 
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At any time, the Scia Engineer Structural model can be reviewed in order to help with visual 
checks. 

 

 
  
After the consistency of the structure is checked, the structure can be meshed and analysed and 
the results in the frame elements, plates and shells can be evaluated. 
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Step 3: Autodesk® Revit® Structure 
After the analysis and optimisation the model is sent (and updated) back to Autodesk Revit 
Structure 

 

Revit link 

The Revit link is a tool which allows transferring the Revit project to the Scia Engineer. The link 
is implemented to the Revit structure applications (as a plug-in). It is displayed in the tab Add-
ins. There are buttons and dialogues which provide link between Revit and Scia Engineer. 
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The supported versions are up to the Revit structure 2012.The setup can be found on the 
installation DVD of Scia Engineer or on the secured download web site for Scia users. 
  
The file format which is used between Revit and Scia Engineer is R2S (Revit to Scia). 

Installation and the setup of the Revit link 

How to find the Revit link on the web 
The secured download page is in Service Packs > Scia Engineer. The link can be also found in 
the setup of Scia Engineer. 
  
Main menu        Instalation&software        Tools       Download Revit plug-in 
  

 
  
This tool will start the download web site for the Revit link. 
It is http://www.scia-online.com/en/revit.html. 

 

How to find the Revit setup on the installation DVD 
The folder with the Revit link setup file can be found here: 

 Setup       DISK1       RevitLink       revit_setup.exe 
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The process of the installation 
Installation of the Revit link is a standard tool. During the process is required to define a Revit 
version and also the correct path where the Revit link should be installed. Then the installation 
can continue in a standard way. 
  
The plug-in is is automatically installed to the selected Revit structure in tab Add-ins. 
  
The installation of the Scia Engineer application itself is not required. The installation of any 
additional Scia Engineer tool is not necessary. 

Note 

         If there are more Revit structure versions on the computer user have to choose the one for 
the plug-in. 

 

The Revit link options 
The Revit link is installed to the Revit structure tab named Add-ins. 
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Options 
There are several functions which affect what can be transferred to the Scia Engineer. These 
functions can be found in the Options dialogue. 
  

 
  
The Revit link exports structural 1D members and 2D members with openings. The supports can 
be exported as a Foundation blocks or Standard supports. 
The Revit link exports the whole or the selected part of the structure from the Revit project. 

Launching of the Scia Engineer 
The export tool can launch Scia Engineer application automatically or save the project as a R2S 
format. The Scia Engineer version which is launched and national code for an exported project is 
defined by the Options. 

 
  
If the Scia Engineer is not launched automatically then there are two possibilities: 

1)     The Export tool will ask for the path where the R2S file will be saved (option Prompt for file 
to YES). 

2)     R2S is saved automatically to the default folder. User is not disturbed at all (option Prompt 
for file to NO). 

  
The R2S file can be imported to the Scia Engineer via the standard import tool. 
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Mapping materials and cross-sections 
The mapping between the Revit and the Scia Engineer is based on tables. There are three types 
of mapping tables – user-defined table, tables based on national codes and mapping rules. 
  

Preferred tables 

This dialogue defines which predefined tables should be used. There are mapping tables based 
on national codes and also user defined table in the list. 
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The top tables in the list have the higher priority. The mapping is done preferably by them. The 
checkbox can deactivate table for mapping. The buttons Up and Down is used for moving the 
selected table in the list. 
  

Mapping rules 

Source and target rules 
The mapping rules can be used when mapping by tables is not sufficient anymore: 

1)     There are too many items for mapping 

2)     There is no sufficient table and the mapping has to be done manually – some specific 
project or a national code. 

  
It is used when the combobox is set to “Use If not found” or “Use mapping rules only”. 

 
The mapping rule requires mapping item to item. Each rule defines the name in the Revit 
(Source table) and the name for the Scia Engineer (Target table). This is not based on libraries 
from the Revit or the Scia Engineer but on exact naming. 
  
The example with the L section: 
  
The source and the target table 

 
  
The explanation of the name composition: 

 

Note 

         The star symbol can be used to map the section as a particular family in the Scia 
Engineer. This can define the section which is not in the Revit actual model but should be 
adapted later in the Scia engineer. 
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Revit family mapping 
The Revit family mapping dialog specifies the mapping of the section types to the Revit family 
names. 
  

 
  

Revit family path 
The Revit family path dialogue allows user to define the path of another Revit family which is 
saved on his computer. 

 
  

Tables 

This is a dialog which shows the whole database of mapping. These tables are based on the 
libraries taken from the Revit and Scia Engineer. 
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User table is clearly user defined. The new mapping rule can be added by the dialogue button 
“Add”. User selects the section name in the Revit and the corresponding name in the Scia 
Engineer. 

 
  
The rest of the tables are predefined by the system. 

 
  

Note 

         If the user table contains rules with the higher priority then it must be moved in the list to 
the top. This table will be used in advance for exporting. 
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Exporting the structure from Revit to Scia Engineer 
The model in the Revit structure has to be saved before it is exported to the Scia Engineer. 
  
The export button is in the Add-ins tab and in the Options dialogue. Both start exporting the 
structure from the Revit structure to the Scia Engineer. 
  

 
  
The dialogue displayed during export shows the number of items which were exported and their 
status. The information about the whole process is displayed in the log part. 
The exporting status is also displayed on the progress bar. 
  

 
  
The log can be saved to the text-file when the export is finished. 
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Scia Engineer is opened automatically if it is set in the option dialogue. Newly exported structure 
is displayed in the model window. 
  

 

Import the structure from Scia Engineer to Revit 
The import button is in the Add-ins tab and also in the Options dialogue. Both start importing the 
structure from the Scia Engineer to the Revit structure. 
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The Revit link is mainly developed for exporting the data from the Revit structure to the Scia 
Engineer. Only some smaller changes made in the Scia Engineer can be imported back to the 
Revit. 
  
This functionality has its limitations. The Revit API doesn’t allow deleting item in the Revit when it 
is imported for the Scia Engineer. It is possible only to modify what is already exported. 
  
The possible modifications are clearly described in the next four examples. 
  

Example no.1 - modification 
Adapt the column cross section in Scia Engineer and import it back to Revit. 
  

 
The default cross-section Cross-section is adapted to square 
  



Export, Import, Roundtrip 

50 

 
Updated cross section in Revit 
  
The log content: 

 
  
The result: The Revit cross section is modified after the import. 
 
 
  

Example no.2 - copy 
Copy exported column in Scia Engineer and import it back to Revit: 
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The result: The Revit structure adds one more column after the import. 
 
 
  

Example no.3 – create new on exported 
Create new opening in the wall and import it back to Revit: 
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            The result: The Revit structure creates new opening in the wall after the import. 
 
 
  

Example no.4 – create new item 
The Revit link is not the tool for importing the whole new structure from the Scia Engineer to the 
Revit structure, but in the simple cases is possible to add a new item: 
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            The log content: 
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            The result: The Revit structure creates new column after the import. 
  

When something is not exported 
This can be caused by a several reasons. 

The cross section or material is not correctly mapped 
This information can be found in the log. 

  

 

Not exported items can be selected and showed by the tool Filter. 

  

 

  There is information why the item was not exported. 

  Checkbox displays only objects with a bad geometry. 

  Show button selects and zoom the item in the Revit model window. 
 
 
  

The dialogue Option ignore the entity 
There is a possibility to ignore 2D member during the export. When this functionality is used the 
2D member is not exported to the Scia Engineer. 
  
This can be found in the log: 
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The object is not supported by the Revit link 
The exportable objects are the structure objects. If the model contain any architectural entity this 
won’t be exported to the Scia Engineer. 
  
If the model is created in the Revit architectural then the model must be edited so the objects are 
switched to the structural ones. 
  

The object is not supported by the Scia Engineer 
Some objects are specific so they don’t have any corresponding entity in the Scia engineer. 
Some of those are not yet implemented. 





 

57 

IFC 

IFC interface 

  
Format IFC (Industry Foundation Classes) allows for transfer of projects and models between 
applications which are used in a building industry. The objective is to simplify the work. 
  

In which way can you import and export by means of IFC? 
At first we would like to explain you the IFC format terminology. Each member (entity) can be 
described in IFC format in several ways. This is called the representation of an entity. We 
support following representation types: 
SweptSolid – import and export of straight 1D and flat 2D members and export of steel 
connection plates. 
Brep – import and export of all entities which we allow to import and export. 
CSG – only for import, the result is always a general volume. 
Clipping – import and export, the result is shown in a structural model. 
AdvancedSweptSolid – import and export of concrete reinforcement. 
SectionedSpine – only for export of arbitrary and haunched beams. 
MappedRepresentation – import and export for particular cases. 
GeometricCurvedSet – export of linegrids. 
  

SweptSolid 
SweptSolid – means that a profile (or an area) is defined and it is extruded along an axis. 
Members defined with SweptSolid representation are converted into Scia Engineer as native 1D 
or 2D members. 
  
Example of a beam with a rectangular profile 

 
  

Example of a column with an I profile 
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Example of slab with a curved edge 

 
  

Brep 
Brep (=boundary representation) – means that an entity is described with vertexes (points) which 
are connected with lines to create a volume. These ones are imported like general volumes 
(solids) to Scia Engineer. In this case it is possible to use an option for automatic recognition of 
members. This function tries to convert the general volumes to beams, columns, walls or slabs. 
  

CSG 
CSG (= constructive solid geometry) – allows Booleans operations (union, difference and 
intersection) between solids. 
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Clipping 
Clipping – means that entity is defined as SweptSolid with a cut-out by plane or other way. 

 
  
AdvancedSweptSolid 
This representation defines the geometry by means of diameter and centre line. The entity 
profile is always a circle. 
  
SectionedSpine 
This representation allows defining of two or more different profiles for a beam or a column. 
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MappedRepresentation 
Allows using of one defined geometry for more entities. 

Beam and column profiles 
After the import beams and columns have one of the following profile types (cross-section): 

         cross-section from the Profile Library - if the same name is found in Scia Engineer 
database, 

         cross-section from Geometric shapes - if the profile is defined by parameters in the IFC 
file, 

         a general cross-section. 

  
Parametric profile example 

 
  
General profile example 
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Composed profile example 

 
Derived profile example 

 
Thin-walled profile example 
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What is possible to import and which way 

         flat walls and slabs with openings and a constant thickness 

         flat walls and slab with recesses and a constant thickness 

         circular arc walls without openings and recesses (with openings and recesses only in 
the structural shape) 

         slabs with circular arc edges 

         1D members with openings 

         shells, curved 1D members, beams with a haunch and arbitrary beams – only as 
general volumes 

         steel connection parts as plates and bolts – in the current version only as general 
volumes 

         concrete reinforcing bars as free bars if the geometry is described in IFC file 

         IFC predefined attributes for beams, columns, members, walls and slabs 
  

What is possible to export and which way 

         flat walls and slabs with openings 

         flat walls and slabs with subregions where the subregions are defined as recesses 

         circular arc walls and slabs with circular arc edges 

         1D members with openings 

         shells and curved 1D members – only with boundary representation 

         2D members with cut-outs – only with boundary representation or without cut-outs 

         parameters with their values which are defined as an attribute of 1D or 2D members as 
member property 

         IFC predefined attributes for beams, columns, members, walls and slabs 

         beams with a haunch and arbitrary beams – with SectionedSpine or boundary 
representation 

         steel connections as plates and bolts 

         concrete reinforcement of 1D members and free bars as reinforcing bars 

         concrete reinforcement of 2D members as reinforcing mesh 
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         storeys as building storeys 

         circular and rectangular 2D line grids and 3D rectangular line grid as more 2D line grids 

         colour of entity by layer 
  
 

  
  
  
  
  

Import 

Procedure 

1.     Open Scia Engineer. 

2.     Run File > Import > IFC 2x3. 

 

3.     Select an IFC file in dialog Open and confirm with [Open] button. 

4.     Choose the way which a model should be imported. Confirm with [OK] button to complete 
the import. 
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Options: 

         Import as members 
It means all members defined with SweptSolid representation will be imported like 
Scia Engineer native members (both 1D and 2D members). 

         Import as general solids 
All members will be imported as general volumes. 

         Import analysis shape only 
Only member shape will be imported without clipping on members. 

         Run member recognizer 
This option runs a member recognizer which will try to convert brep members (general 
solids) to Scia Engineer native members. 

         Import stories as layers 
If  an IFC file contains some building storeys and the option is ON then each storey is 
a separate layer in Scia Engineer. The layer name is the same as the storey name. 

         Material table 
If material names in the IFC file are not in accordance with code names it is necessary 
to define a material conversion table. If no table exists default materials are assigned. 
Button [Choose file…] allows for the selection of the file with the material table. 
Modifications can be made through button [Edit]. The file has *.con file extension and 
it is a plain-text file, for example: 
[materials] 
; 
Concrete1=C12/15 
Concrete2=C25/30   
The first name is name of material in the IFC file and the second one is the code 
name of material used in Scia Engineer. It is necessary to respect all characters. 

         National code 
The code in which the imported project will be open must always be selected. 

  

5.     A dialog with the progress of import is displayed. 
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6.     A dialog with the import report is displayed. To finish the import press the [OK] button. To 
save the import report press the [Save as...] button. 

 

7.     In order to creating a proper analysis model  it is necessary to use Connect and Align 
functions. 

 

Update 

Procedure 

1.     Open Scia Engineer project which has been updated. 
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2.     Run File > Update > IFC 2x3. 

 

3.     Select the IFC file which is to update the project and confirm with [Open] button. 

4.     Choose the way which the model should be imported. Confirm with the [OK] button. 

 
  

Options: 

         Import as members 

         Import as general solids 
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         Import analysis shape only 

         Run member recognizer 

         Import stories as layers 

         Material table 

         National code 

Note: For the explanation of options see the previous chapter. 

5.     A dialog with the progress of import is displayed. 

 

6.     A dialog with the import-report is displayed. To finish the import press [OK] button. To 
save the import-report press [Save as...] button. 

 

7.     The import is finished and comparison of the two projects (the original one and changed 
one) is launched. The procedure is similar to ESA-ESA Update. 

 

Note: Though Update function helps to save your time, it is necessary to respect some 
disadvantages of IFC, such as: 
- the IFC format describes only member surfaces. That means if you have the structure 
connected and aligned after update it will be detected like changes. 
- All member nodes are generated during the import, i.e. during update the nodes are in 
groups Deleted entities and New entities. 

  
  

Export 

Procedure 

1.     Open Scia Engineer file. 
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2.     Run File > Export > IFC 2x3. 
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3.     Write a name of IFC file in dialog Save As and confirm with [Save] button. 

4.     Choose the way which the model should be exported. Confirm with [OK]. 

  

 

Options: 

         SweptSolid 
All members that can be exported as a profile (area) extruded along an axis and 
cross-sections that can be described with parameters will be written this way to the 
IFC file. 
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         SweptSolid, not using parametric profiles 
The same as previous option except cross-sections. All cross-sections are exported 
as general profile. 

Note: Not all applications are able to read parametric profile. 

         Brep 
All members are exported with boundary representation, i.e. no profiles are defined, 
etc. 

         Use SectionedSpine representation 
If ON, all beams with a haunch and arbitrary beams are exported by means of the 
SectionedSpine representation. If OFF, all beams and columns are exported with 
prismatic profiles. 

Note: Not many applications support this representation type. 

  

5.     A dialog with the export-progress is displayed. 
  

6.     A dialog with the export-report is displayed. To finish the export press [OK] button. To 
save the export report press [Save as...] button. 

  
  

 

7.     The IFC file is written. 
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SDNF 

SDNF Interface 

  

Import 

Project data 
  

 
  
Project data which are loaded from the SDNF file: 

-       Name is “Project Id” 

-       Part is “Structure Id” 

-       Description is “Client Id” 

-       Author is "Engineering Firm Id" 

-       Date is correctly loaded  from *.sdn file 
  
 
 
  

1D members         

Member types: 

-       column is imported as column 
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-       types beam and brace are imported as beam 
  

Profiles 
 – if the same name of profile is found in Scia profile database or if a user conversion table is 
defined 
  

Material 
– if the same name of material is found in Scia material database or if a user conversion table is 
defined 
  

Member properties: 

-       cardinal points are correctly set as “Member System At” property 

-       eccentricity – ez,ey is read from file 

-       correct position and orientation of begin  and end node of member 
  

Add data 

Supports/hinges 
Supports and hinges are automatically generated from the defined releases in the file. The 
conversion is based on certain rules and not always the result is as what the user expects. 
  

Procedure: 
1. Run File > Import > SDNF file 
  

 
 
2. Choose .sdn file and confirm dialog Open. The version of SDNF is recognized by a record 
inside the file. 
 
3. Choose a code 
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4. Import dialog is displayed. It is possible to select user defined tables for profile and material 
conversion. At the bottom of dialog there is a check box Import only structure. If ON, only 1D 
members with properties will be imported. If OFF the releases defined in the file will be taken in 
account. 
  

 
  
  
 
5. After the import a report is shown summarising how many entities were imported. 
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6. A project is opened. 

  

Export 

Project data 
Project data which will be saved to the file: 

-       Name is “Project Id” 

-       Part is “Structure Id” 

-       Description is “Client Id” 

-       Author is "Engineering Firm Id" 

-       Date is correctly written to *.sdn file 

1D members         

 Member types 

-       column is exported as column 

-        type beam is exported as beam 

-       others types are exported as brace 
  
  
Profile names and material names are written to the file. No conversion table is possible for 
export 
  
  

Member properties 

-       member system is set as correct cardinal points number 
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-       alpha of cross-section and/or LCS rotation 

-       eccentricity – ez,ey is written as cross-section offsets 

-       correct position and orientation of begin  and end node of member 
  

Add data 

Supports/hinges 
- both is exported as member releases to the file 
  

Procedure: 
1. Run File > Export > SDNF file 
  

 
  
2. Define a file name and confirm dialog Save as. 
  
3. Export dialog is displayed. The user can choose the version of SDNF format and confirm with 
[OK]. 
  

 
  
4. Export report dialog is opened. 
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4. A file with sdn file extension is created. 



 

77 

DSTV 

DSTV 
Scia Engineer allows for both import and export of files in DSTV format. 
The interface is based on the format according to: 
Schnittstellenkonvention Statik-CAD, Köln : Deutscher Stahlbau-Verband, 1993 
  

Note: Only steel frame structures (i.e. structures composed of 1D members) can be imported/exported 
through DSTV format. 

  

Note: More information about the DSTV format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

DSTV import 
The import is based on the file with extension SC2. Parts *B00, *B01, *B02, *B03 and *B04 of 
this file are read into Scia Engineer. 
  

The contents of the .SC2 file (origin : analysis) 

Part Description 

*B00 General information (units, delimiters, etc.) 

*B01 Topology of 1D members 

*B02 Nodal co-ordinates 

*B03 Names of cross-sections 

*B04 Properties of 1D members 

  

Note: More information about the DSTV format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

  

The procedure to import data from DSTV file 
1. Start menu function File > Import > DSTV. 
2. Browse for the required .SC2 file. 
3. Finish the import. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

DSTV export 
Scia Engineer generates files with extension SC1, SC2, SC3. 

The contents of .SC1 file (origin : CAD) 

Part Description 

*A01 Assembly definition 
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The contents of .SC2 file (origin : analysis) 

Part Description 

*B00 General information (units, delimiters, etc.) 

*B01 Topology of 1D members 

*B02 Nodal co-ordinates 

*B03 Names of cross-sections 

*B04 Properties of 1D members 

  
The cross-section names written in this file can be the original Scia Engineer names or the 
corresponding DSTV names. In order to have the DSTV names in the output file, you have to 
select the option "Use DSTV name conversion for section name". A dialogue with this option 
appears on the screen during the export procedure. 

The contents of .SC3 file (origin : analysis) 

Part Description 

*C01 Assembly definition 

  

Note: More information about the DSTV format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

  

The procedure to export data into DSTV file 
1. Start menu function File > Export > DSTV. 
2. Specify the required output folder. 
3. Type the name of the file (i.e. the base name without extension). 
4. Confirm the input. 
5. During the export procedure a dialogue opens on the screen. 
6. Decide whether to "Use DSTV name conversion for section name" or not. 
7. Complete the export. 
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ProSteel 

Pro Steel 
The exchange of data between Scia Engineer and PeoSteel programs is achieved through a 
special format developed by companies KIWI software and SCIA. It is a XML-based format and 
the files use extension .PRO. 
The format has been designed to support the following entities: 
 straight steel 1D members, 
 rolled cross-sections, 
 connections: (i) end plate and (ii) frame connections for strong axis. 

  
In order to use this feature, the user must have installed ProStell v.17 or later. 
Both import, export and update functionalities are available for this format. 

Pro Steel import 

The procedure to import data from Pro Steel file 
1. Start menu function File > Import > ProSteel. 
2. Browse for the required input file. 
3. The import dialogue opens on the screen. 
4. Set the required options – see below. 
5. Confirm with [Import]. 

  

Import from ProSteel dialogue 

"graphical window of 
the dialogue" 

It displays the structure to-be-imported. The 
user may preview here the data from the file-
to-be-imported. In addition, the window 
makes it possible to review the result of the 
automatic connection of 1D members. 

The window supports standard features of 
Scia Engineer graphical windows: 

(i) pop-up menu with a set of zoom, print, 
save etc. functions, 

(ii) [Ctrl] + [Shift] + right-click and drag to 
zoom in and out the drawing, 

(iii) [Shift] + right-click and drag to move the 
drawing, 

(iv) [Ctrl] + right-click and drag to rotate the 
drawing. 
  

Auto-connect 
members 

If ON, the import procedure automatically tries 
to connect entities of the imported model in 
such a way that the result is a correct analysis 
model. 

If OFF, the 1D members are imported in their 
actual positions, which does not guarantee 
that the imported model can be analysed by 
means of FEM algorithm. Some modifications 
and tuning of the imported model may be 
necessary to satisfy the prerequisites of the 
finite element method. 
  

Max. distance If the distance of two points in the imported 
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structure is smaller than the value specified 
here, the program tries to "merge" the points 
into one. 

If the distance of two points is greater then 
the value specified here, the two points are 
treated as separate points and the connection 
algorithm does not try to "merge" them. 
  

Display report If ON, the program issues a report about the 
import. 
  

Refresh image This button performs in fact two actions: 

(i) it starts the connection algorithm which 
connects the 1D members, so that the result 
of the import is a correct FEM analysis model, 

(ii) it refreshes the image in the graphical 
window of the dialogue. 
  

Import This button imports the data into the main 
environment of Scia Engineer. 

Note: If the option Auto-connect members 
is ON and the button [Refresh image] has 
not been clicked yet, the button [Import] is 
disabled. The reason is that the user should 
review in the graphical window the result of 
the connection algorithm, so that he/she may 
get the chance not to accept it. 
  

Cancel This button enables the user to abandon the 
current action. 
  

CAD model This disabled item has no meaning in the 
current version. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

Pro Steel export 

The procedure to export data into ProSteel file 
1. Start menu function File > Export > Pro Steel file. 
2. Specify the required output folder. 
3. Type the name of the file (i.e. the base name without extension). 
4. Confirm the dialogue. 
5. During the export procedure another dialogue opens on the screen. 
6. Select if you want to export the analysis or structural model – see below. 
7. Complete the export. 

  

Structural versus analysis model 
Scia Engineer enables the user to export either the analysis model (used for FEM calculations) 
or the structural model (used for drawings). 
The difference between the models can be best demonstrated on a simple example of a planar 
frame. 
Let us have a simple frame: 
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The analysis model is the shape idealised for the needs of FEM analysis. It is an ideal axial 
model of the structure. 

 
On the other hand, the structural model (shown in fact in the first picture) shows the real position 
and connection of individual structural members. Consequently, the "axial" representation of 
such model is different from the idealised FEM model. 
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The difference (and also problem during the import into calculation programs) is that the 1D 
members and columns do not intersect each other. This problem must be sorted out (somehow) 
after the import of the structural model into a FEM-analysis program. 

Pro Steel update 
Once a project created (or at least processed) in Scia Engineer has been exported to ProSteel 
format and handled outside of Scia Engineer, it is likely that some changes have been made to 
the project data. 
In general, this may be a cause of troubles as someone must review both variants of the model 
(project in Scia Engineer and the third-party-processed file) and decide what to do. 
In order to facilitate this task, Scia Engineer offers the Update function that compares the two 
variants and merges them together according to user-defined rules. 
  

The procedure to update the project through ProSteel file 
1. Open in Scia Engineer the project to-be-updated. 
2. Call function File > Update > ProSteel. 
3. Browse for the file to-be-merged. 
4. The Update from ProSteel dialogue is opened on the screen – see below. 
5. Select the type of changes that you want to accept. 
6. Confirm with [Update]. 
7. If some new entities were added by the third-party, the Import from ProSteel dialogue is 

opened on the screen. 
8. Fill in the required options and perform necessary actions. 
9. The update is completed. 

  

Update from ProSteel dialogue 

Group Update 
This group contains a list of types of items that are compared during the update operation. If 
some items are not relevant for the particular update operation, they are disabled. Only the 
enabled items have been diagnosed by the update algorithm as relevant ones. 

Added members If the ProSteel file contains some new 
members (in comparison with the currently 
open project), the user may use this checkbox 
to decide whether the added members should 
be merged (item is ON) or ignored (item is 
OFF). 
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Deleted members Analogous to the above. 

If ON, the members deleted from the merged 
file are deleted from the current project. 

If OFF, any deletions made in the ProSteel 
file are ignored. 
  

Changed geometry If ON, all the changes of geometry are taken 
into account. 

If OFF, the changes of geometry are ignored. 
The geometry remains as it is in the currently 
open project. 
  

Changed cross-section If ON, any changes of cross-sections are 
taken into account. 

If OFF, the changes of cross-sections are 
ignored. The cross-sections remain as they 
are in the currently open project. 
  

Added connections Analogous to above – but this time related to 
connections. 
  

Deleted connections Analogous to above – but this time related to 
connections. 
  

Changed connections Analogous to above – but this time related to 
connections. 
  

  

Other controls 

Display report If ON, a report is generated about the update 
operation. 
  

Button [Update] This button performs the update (taking into 
account the adjustments made in group 
Update). 
  

Button [Cancel] This button cancels the whole update 
operation. 

  

Graphical window 
It displays the structure to-be-updated and shows the found changes. The changes are 
displayed in colour. Each type of change uses a specific colour that is indicated in the group 
Update of the dialogue. 
The window supports standard features of Scia Engineer graphical windows: 
(i) pop-up menu with a set of zoom, print, save etc. functions, 
(ii) [Ctrl] + [Shift] + right-click and drag to zoom in and out the drawing, 
(iii) [Shift] + right-click and drag to move the drawing, 
(iv) [Ctrl] + right-click and drag to rotate the drawing. 
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Note: The behaviour of the update-function may differ in some details from the description given here 
as the interface is still under development on both sides, i.e. Scia Engineer and ProSteel. 
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StepSteel 

StepSteel - analysis model 
The interface provides for the exchange of data with StepSteel and is based on the following 
references: 
(1) 
Standardbeschreibung Produktschnittstelle Stahlbau 
Teil 1 : Emphehlungen für den Anwender 
DSTV – Arbeitsausschuss EDV 
April 2000 
(2) 
Standardbeschreibung Produktschnittstelle Stahlbau 
Teil 2 : DatenModell 
DSTV – Arbeitsausschuss EDV 
April 2000 
(3) 
Standardbeschreibung Produktschnittstelle Stahlbau 
Teil 3 : Implementierungsbereiche und Konformitaetanforderungen 
DSTV – Arbeitsausschuss EDV 
April 2000 
  
The implemented EXPRESS-scheme is PSS_2000_04.exp. 
  
Scia Engineer allows for both import and export of StepSteel files. In addition to the analysis 
model, also the structural model can be imported and exported – this is described in separate 
topics. 
  

Note: Only steel frame structures (i.e. structures composed of 1D members) can be imported/exported 
through StepSteel format. 

StepSteel - import of analysis model 

The procedure to import data from StepSteel file 
1. Start menu function File > Import > StepSteel. 
2. Browse for the required input file. 
3. Finish the import. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

  

Note: More information about the StepSteel format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

StepSteel - export of analysis model 

The procedure to export data into StepSteel file 
1. Start menu function File > Export > StepSteel. 
2. Specify the required output folder. 
3. Type the name of the file (i.e. the base name without extension). 
4. Select the output level – see below. 
5. Adjust parameters relating to section names – see below. 
6. Complete the export. 
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Available implementation levels 

Implementation level Entity 
group 

Abbreviation 
  

Note 

Reading analysis 
structure 

'Statische Struktur 
Einlesen' 

General 
data 

Analysis 
data I 

1(IN) 
  

Not 
available 
for export 

Writing analysis 
structure 

'Statische Struktur 
Schreiben' 

General 
data 

Analysis 
data I 

1(OUT) 
  

  

Reading analysis 

'Statik Einlesen' 

General 
data 

Analysis 
data I 

Analysis 
data II 

2(IN) 
  

Not 
available 
for export 

Writing analysis 

'Statik Schreiben' 

General 
data 

Analysis 
data I 

Analysis 
data II 

2(OUT) 
  

Two 
options 
available 
for export: 
with and 
without 
results. 

Writing design 

'Entwurf Schreiben' 

General 
data 

Design 
data 

3(OUT) 
  

  

  

Note: More information about the StepSteel format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

  

Section names 
The cross-section shape is recognised from the name of the cross-section. The user may adjust 
a few parameters that influence the applied conversion of cross-section names. 

Use DSTV conversion 
for section names 

If ON, the DSTV convention is used for cross-
section names. 

Use mapping table as 
conversion for section 
names 

If ON, the mapping table is used to convert 
the names of cross-sections. 

StepSteel - structural model 
The import and export of structural model is an extension to the import and export of the analysis 
model. 
  

Note: Only steel frame structures (i.e. structures composed of 1D members) can be imported/exported 
through StepSteel format. 



StepSteel 

87 

StepSteel - import of structural model 

The procedure to import data from StepSteel-CAD file 
1. Start menu function File > Import > StepSteel-CAD. 
2. Browse for the required input file. 
3. Finish the import. 

  

Note: The import function creates a new empty project and the specified file is imported into it. 

  

Note: More information about the StepSteel format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 

StepSteel - export of structural model 

The procedure to export data into StepSteel-CAD file 
1. Start menu function File > Export > StepSteel-CAD. 
2. Specify the required output folder. 
3. Type the name of the file (i.e. the base name without extension). 
4. Complete the export. 

  

Note: More information about the StepSteel format can be found in a separate SCIA manual titled Scia 
Engineer ASCII Import/Export Manual. 





 

89 

CEA Plant-4D 

CEA Pland-4D 
Scia Engineer allows for export of project data into CEA Pland-4D file. This option is available 
only if the corresponding software is installed on your computer. 
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Tekla 

Tekla 

Note: This import/export capability is not directly related to Scia Engineer functionality. Nevertheless, it 
can prove useful to Scia Engineer users. Please, consider this chapter to be only a brief introduction and 
contact SCIA support team for more information and/or guidance. 

  

Note: The interface works with Tekla Structures versions 15 and 16. 

If IFC format is not a solution for you to export to and from Tekla Structures, you can use the 
STEP Steel format. Alternatively, export can be made through Tekla Structure API link. 
  

STEP Steel format 

Tekla to Scia Engineer 
1. Export a project by StepSteel export option in Tekla Structures to e.g. "Tekla_output.stp". 
2. Open "Tekla_output.stp", and replace the text 

'FILE_SCHEMA(('DATA_SECTION_SCHEMA_3_99'))' with 
'FILE_SCHEMA(('PSS_2000_04'))' in the header, then save it again. 

3. Now import this output-stp ("Tekla_output.stp'" into Scia Engineer. 
4. Make necessary modifications, analyses, checks, etc. 
5. Export the structure into StepSteel CAD format (not levels 1-3), e.g. to "output01.stp" (see 

chapter StepSteel - export of structural model). 
6. Change the header back: So now replace 'FILE_SCHEMA(('PSS_2000_04'))' with 

'FILE_SCHEMA(('DATA_SECTION_SCHEMA_3_99'))'. 
7. Then save it as "output01e.stp". 

  

Scia Engineer to Tekla 
1. In Scia Engineer you have to generate a new STP-File (e.g."Esa_output.stp'". Choose the 

option: Stepsteel export CAD (not levels 1-3) (see chapter StepSteel - export of structural 
model). 

2. Open "Esa_output.stp", and replace the text 'FILE_SCHEMA(('PSS_2000_04'))' with 
'FILE_SCHEMA(('DATA_SECTION_SCHEMA_3_99'))' in the header, then save it again. 

3. Now import this output-stp ("Esa_output.stp'" into Tekla Structures. 
  

Tekla Structure API link 
The link is based on Tekla Structure API supports the export of: 
- Geometry of straight beams and columns (beginning- and end-nodes) 
- Materials using the mapping database 
- Cross-sections due to mapping database or geometrical profiles (except twin profiles) 
- Eccentricity, ey,ez 
- Member system-lines 
- welded cross-section, 
- hinges. 
  

General procedure 
1. Call File > Export > Tekla file. 
2. File with .s2t extension is created. 
3. Then it is needed to run Tekla plugin – Scia2Tekla.exe. 
4. Load .s2t file, material and cross-section mapping database - otherwise the default profile 
(rectangle 10x10) is used. 
5. Press button Load Data into Tekla Structures. 
6. In Tekla Structures the project is imported. 
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Note: Tekla Structure has to be running before the step 5 is done. 
  

Export dialogue 

 
  

Menu File 
- New  – opens a new dialogue Scia2Tekla plugin without any settings (clears previous settings) 
- Open – opens a dialogue for to select an existing *.sts (Scia to Tekla settings) file. 
- Save – saves the user settings in the dialogue to *.sts (Scia to Tekla settings) file. 
- Save as – saves the user settings in the dialogue to *.sts (Scia to Tekla settings) file. 
- Close – closes the plugin dialogue . 
  

Dialogue items 

File from Scia Engineer 
It loads s2t file which should be imported to Tekla Structure. 

Name of new project in Tekla 
It is possible to define a name of Tekla model. 

Scia Engineer model 
Either the Analysis or the Structural model can be selected for export. 

Material mapping database 
It loads XML file which contains conversion table for materials 

Cross section mapping database 
It loads XML file which contains conversion table for profiles 

[Load data into Tekla Structures] 
It runs an import of defined file to Tekla Structures 

[Edit material database] 
It runs a dialogue for defining and editing of conversion table for materials 
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[Edit CSS database] 
 It runs a dialogue for defining and editing of conversion table for cross-sections 

[Close] 
It closes the dialogue. 
  
  
At the bottom of dialogue is a window where a log is written. Above this window it is possible to 
choose what kind of information should be displayed. On the right side it is possible to define a 
text file to which the log will be saved. 
  

Mapping database editor 
  

 
  
Mapping databases are stored in XML. 
The mapping database contains information about versions of Tekla structures for which it was 
tested. 
Two working modes are available: Administator (SCIA emploee) and User: 
              - Administrator can create the master database, 
              - User can create only "user database". 
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Google Earth 

Google Earth 

Note: This import/export capability is not directly related to Scia Engineer functionality. Nevertheless, it 
can prove useful to Scia Engineer users. Please, consider this chapter to be only a brief introduction and 
contact SCIA support team for more information and/or guidance. 

  
The export of your structure to Google Earth can be done in two steps. 

1. The model of the structure must be exported to IFC format (see chapter IFC export). 
2. The IFC file must be converted into .KML format. This format can be then opened in Google 

Earth. 
  
Tip: A free tool IfcStoreyView can be used to make the conversion from .IFC to .KML 
format. 
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ETABS 

  

Interface with ETABS 

Why and how to use? 
There are lots of reasons why the interface between Scia Engineer and ETABS may be . Some 
users can need to use curved members others can need to use a steel check of hall. The next 
ones can want only to work with more customized environment. All this we can to provide to 
users. But they have got more projects in ETABS format and they surely do not want to lost them 
with changing of software and this is the reason why the interface with ETABS was developed. 
User can import project to Scia Engineer and to finish her/his work there. This interface cannot 
import everything at this moments but it is clear then  a development of the interface will be 
continue in next versions of Scia Engineer. 
  
  

What is better in Scia Engineer? 
 It knows: 

-       Curved beams. 

-       Curved walls. 

-       Lots of possibility to create shells. 

-       Better displaying of structure. 

-       Different types of results. 

-       More possibilities of reinforcement of concrete structures. 

-       More possibilities of checks (steel, concrete,..). 

-       Steel connections etc. 

-       More type of supports – line, surface,.. 

-       Variable load on slabs. 

-       Free loads. 

-       Variable thickness of 2D and subregions. 

-       Haunches and arbitrary beams. 

  

e2k file 
  
The exchange of data between ETABS and Scia Engineer is done through the e2k file. This type 
of file can be created and also read-back in a standard version of ETABS. Scia Engineer offers 
the possibility to import and export this type of file in its standard File > Import and File > Export 
menu. 

Import 
  
This chapter explains what data are read during the import of e2k file. At the end of the chapter 
you will find the procedure how to make the import of e2k file to Scia Engineer. 
  

Project data 
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Name 
Name is filled in with the Model Name defined in e2k file. 
Author 
Author is filled in with the Company Name defined in e2k file. 
Description 
In Description there is the Etabs version which the e2k file was exported from. 
  
  

Units 

-       Units are calculated in accordance with Scia Engineer units and the entire structure is 
imported in basic units (kN/m). 

  

Nodes 

-       Names of nodes are generated during the import. 
  

Beams and columns 

-       Beams are imported as 1D members with the type set to beam. 

-       Columns are imported as 1D members with the type set to column. 

-       Braces are imported as 1D members with the type set to beam. 

-       Line members with “none” profile are imported as 1D members with very a small cross-section 
and they are inserted to a special layer named NullBeam which is marked as CAD only. That 
means it is not taken in account during calculations. 

-       Properties: member system, type, cross-section. 
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Cross-sections 

-       Cross-section conversion table (a default one is distributed with Scia Engineer and users can 
create their own by means of tools distributed with Tekla-plugin). 

-       Geometric profiles (rectangular and circular shapes). 

-       If a profile is defined as auto-select section in ETABS, the first one from the auto-select section 
list is taken in account as the profile of the member during the import. 

  

Walls and slabs 

-       Walls are imported as 2D members with the type set to wall. 

-       Slabs, decks and planks are imported as 2D members with the type set to slab. 

-       Ramps are imported as 2D members with the type set to slab. 

-       Area members with a “none” profile are imported as very thin 2D members that are inserted to 
a special layer named NullSlab and marked as CAD only. They are not taken in account 
during calculations. 

-       Openings. 

-       Properties: thickness, material, type. 
  

Materials 

-       User defines a conversion table during the import. A dialog for the defining of material 
conversion appears on the screen during the import: 
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-       On the left side there is a list of all materials defined in the imported e2k file. On the right side 
there will be a list of Scia Engineer materials which user assigns to each one from the ETABS 
file. 

-       Click button [Define equivalent materials]. A new dialog with a list of Scia Engineer materials 
for selected code is displayed. 



ETABS 

101 

 

-       At the top part of the dialog there is a combo box where you can choose a type of material, 
such as steel or concrete, or all materials. 

-       Select which one you want to work with and confirm with [OK]. 

-       If all materials are defined a button [OK] is available in the Equivalent material dialog and the 
user can continue with the import. 

  

Supports 

-       ETABS has got only point supports and these can be imported to Scia Engineer. 

-       Each restraint (Fx, Fy, Fx, Mx, My, Mz) is imported correctly as rigid or free. Springs or flexible 
supports are not supported. 

  

Hinges 

-       Beam releases in ETABS are imported as hinges to Scia Engineer. In many cases it will be 
necessary to edit these hinges in Scia Engineer because their philosophy in Scia Engineer is 
different from the definition of releases in ETABS. 

-       Hinges on 2D member edges are not supported. 
  

Loads 
  

-       Point load in point 

Forces Fx, Fy, Fz, and moments Mx, My, Mz in global and local coordination systems 
are supported. 

They are imported as native Scia Engineer forces in node. 
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-       Point (repeating) loads on beam 

Both forces and moments in global or local coordination systems are supported. 

Repeated loads are imported as several separate point forces on beam. It is not 
possible to import them as native Scia Engineer repeated forces. 

-       Line loads on beam 
Both forces and moments with a uniform or a trapezoid distribution in global or local 
coordination systems are supported. 

Load with the trapezoidal distribution is imported as several line loads. Each part of 
trapezoidal load is an independent load in Scia Engineer. 

-       Surface load on slab 

ETABS has got only a constant surface load which is supported for import to Scia 
Engineer. 

-       Temperature 

Point temperature load is not imported because Scia Engineer has no point 
temperature implemented. 

Line temperature load is imported only on 1D members. 

Surface temperature load is imported only on 2D members. 

-       Loads (except temperature)  on line beam with a none profile are imported as free point or line 
loads with selection – select. In the selection there is only the closest member. 

-       Loads (except temperature) on area with none profile are imported as free surface loads with 
selection – select. Only the closest member is in the selection. 

-       Load cases 

All static linear load cases are imported with their name, action type and load type to Scia 
Engineer. 

-       Load combination 

All linear combinations are imported with their lists of load cases. 
  

Procedure 

1.     Call function File > Import > ETABS file. 

 

2.     Dialog Open file is opened on the screen. 
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3.     Select the required e2k file for import. 

4.     Confirm with [Open]. 

5.     Dialog Codes in project appears. 

6.     Select a code and confirm with button [Close]. 

 
  

7.     The Import from ETABS dialog is opened. 

The ETABS version where e2k file was exported from is shown here. The user can 
choose the required user-defined cross-section mapping table or to keep the default one 
which is distributed with Scia Engineer. 

  

 

8.     Press button [Import]. 

9.     The dialog for material conversion defining is displayed. 

10.  Define the materials and confirm with [OK]. 

11.  The import is in progress. A big structure can take some time to import. 

12.  The log is shown. 
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13.  The structure is imported. 

 

Export 

Storeys and line grid 

-       If storeys are defined in Scia Engineer project then they are exported to e2k files. It is 
important to have defined each member in the only strorey. If any member is in no storey or in 
two or more stroreys the member will be assigned to basic one or to the lower one. A basic 
line grid is generated during an export. No line grid from Scia Engineer is exported to e2k file. 

Note: The export of storeys is supported from Scia Engineer 2011 
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Units 

-       A structure is always exported in basic units (kN/m). 
  

Materials 

-       Each material is correctly written to an exported file. 
  

Cross-sections 

-       For export of cross-sections the default (or user) conversion table is used. It is the same table 
which is used for import. 

  

1D members 

-       Straight 

For export only straight members without haunches, arbitrary shapes, openings, etc are 
supported. Polyline members are exported as several members. Member properties as angle, 
profile, material, member system and member type are taken in account. Columns and beams 
are exported as column and beams, others types are exported as brace to e2k file. 

-       Curved 

No curved members are supported for export. All curved members are exported as straight. 
  

2D members 

-       Flat 

Only flat members with straight edges and openings and constant thickness and without 
subregions are supported. Member properties as material and member type are taken in 
account. Member types for export are only wall and slab. If a flat member has got a curved 
edge, the edge is exported by means of straight lines. 

-       Shells 

Shells are not supported for export. They can be exported only as flat members to e2k file. 
  

Supports 

-       Point in node 

For export there are supported only point supports in nodes with rigid or free restrains. If a 
support with a flexible stiffness is defined it is exported as free. 

-       Others 

Point supports on a beam or an internal node, line supports on beam or 2D member edge and 
surface supports are not supported for export and nothing will be exported to e2k file. 

  

Hinges 

-       Hinges on beams are exported as beam releases to e2k file. 

-       Hinges on 2D member edge are not supported. 

  

Loads 
  

-       Point in node 
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Point forces Fx, Fy, Fz, and moments Mx, My, Mz in a node in global and local coordination 
system are supported for export to e2k file. 

Point force in an internal node is not supported. 

  

-       Point on beam 

Both forces and moments in global or local coordination system are supported. 

Repeated ones are exported as several point forces on beam. 

  

-       Free point 

Free point forces or moments are not supported. 

  

-       Line on beam 
Both forces and moments with uniform or trapezoidal distributions in global or local 
coordination system are supported for export. 
  

-       Line on edge 

Line forces on 2D member edge are not supported. 

  

-       Free line 

Free line forces are not supported. 

  

-       Surface 

Only uniformly distributed surface load is supported for export to Scia Engineer. 

  

-       Free surface 

Free surface load is not supported. 

  

-       Temperature 

Only constant thermal loads on 2D members and 1D members are supported. 

If the thermal load is defined as variable it is exported to e2k file as constant load with top 
delta z+. 

  

-       Load cases 

All load cases are exported to e2k file with their action type and load type. 

  

-       Load combination 

All linear load combinations are exported to e2k file with a list of load case. 
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Procedure 

1.     Call function File > Export > ETABS file. 

 

2.     Dialog [Save as] is opened. 

3.     Define the name of the exported e2k file. 

4.     Confirm with [Save]. 

5.     Export dialog is opened. 

It is possible to choose a supported version of ETABS where e2k file should be exported 
to. he user can choose a user cross-section mapping table or keep the default one which 
is distributed with Scia Engineer. 
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6.     Press button [Export]. 

7.     The export is in progress. 

8.     The log is displayed. 

 

9.     The structure is exported to e2k file. 
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ECtools 

ECtools 
ECtools© is a design software for Reinforced Concrete and Unreinforced Masonry Structures 
that aims to facilitate the practicing structural engineer or the design office in the correct 
application of the several clauses of Eurocodes 2, 6 and 8. It utilises the analysis results of SCIA 
Engineer© and can be used in the following cases: 
    * Seismic design of Reinforced Concrete Buildings 
    * Checking/Reviewing the Design of Reinforced Concrete Buildings 
    * Seismic Assessment and Retrofitting of existing Reinforced Concrete Buildings 
    * Seismic design of Composite buildings with Concrete Cores (The cores) 
    * Seismic design of Unreinforced Masonry Buildings 
    * Seismic Assessment and Retrofitting of existing Unreinforced Masonry Buildings 

The procedure to export the project to ECtools 
1) Run function: Plugins > ECtools > ECtools. 
2) Type the name of the file and confirm with OK. 
3) The file (a XML file with corresponding definition (DEF) file) is created. 
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